/*十有三博客*/
  • 首页
  • 关于本站
  • 网站地图
  • RSS订阅

此请求的 URL 的长度超过配置的 maxUrlLength 值

2015-07-07 十有三 0 浏览:1万+ .NET技术 ASP.NET MVC

对于ASP.NET MVC网站来说,网站的URL长度是有默认限制的,URL长度的默认值最大为260个字符。如果HTTP请求的网站地址超出了默认长度,就会抛出HttpException 异常,并显示错误信息:此请求的 URL 的长度超过配置的 maxUrlLength 值。

其实本身太长的URL也是对于网站访问者来说是十分不友好的,但是考虑到需求方面的因素,所以如果要突破ASP.NET MVC的URL长度限制,只要设置下配置文件的httpRuntime 节点的maxUrlLength属性即可,具体web.config中的设置如下:

<system.web>
    <httpRuntime maxUrlLength="9999"/>
</system.web>

另附错误截图:

截图:此请求的URL的长度超过配置的maxUrlLength值

MSDN文档:httpRuntime 元素(ASP.NET 设置架构)


作者:十有三

出处:https://shiyousan.com/post/635718845526700046

版权声明:本文采用知识共享许可协议:署名-相同方式共享 4.0 国际(CC BY-SA 4.0)。欢迎转载本文,转载请声明出处或保留此段声明。


  • 上一篇: ASP.NET MVC:此请求的查询字符串的长度超过配置的maxQueryStringLength值
  • 下一篇: C#中ADO.NET如何传递和设置like查询的参数

相关文章
  • 无法从带有索引像素格式的图像创建 Graphics 对象
  • Discuz!NT Flash无法上传头像,点击上传后无任何反应
  • 解决vs2010添加项目后解决方案资源管理器中没有显示解决方案的问题
  • 如何在ASP.NET的web.config配置文件中添加MIME类型
  • C# string转换成DateTime?(字符串转换成可空日期类型)
  • 翻译:Changes to the language setting will not take effect until the environment is restarted.

文章分类

.NET技术 123 数据库 24 Web前端 21 网站建设运维 37 操作系统与应用 66 程序猿日常 11 开发工具 12 其他随笔 13

文章标签

ASP.NET ASP.NET MVC C# CSS HTML IIS Javascript Linux MongoDB MySql SQL SQL Server Visual Studio Windows系统 版本控制系统 插件工具 服务器 搞笑娱乐 好文分享 软件应用 生活知识 手机问题 随笔 网络知识 网站设计优化 网站维护 养生保健 异常处理 硬件设备 游戏攻略

热门文章

  • IIS8如何安装和使用URL重写工具-URL Rewrite
  • 林蛋大与楚中天,朱肚皮与朱月坡
  • 解决IE11安装升级失败和在安装前需要更新的问题
  • Windows Server 2012无法安装 .NET3.5-安装角色或功能失败,找不到源文件
  • Win10中如何设置Hyper-V的网络让虚拟机也能上外网

推荐文章

  • ChinaPay踩坑笔记一:在64位系统中不支持ASP支付功能
  • IIS8无法将不带www的顶级域名301重定向到带www的域名中
  • OneNote如何取消共享笔记和删除邀请的用户
  • ASP.NET 动态设置 HTTP 500 引发内部服务器错误
  • WP系统升级出现已下载但无法打开(8018830f)

友情链接

  • 码友网

知识共享许可协议 CC BY-SA 4.0本站作品采用知识共享许可协议:署名-相同方式共享 4.0 国际(CC BY-SA 4.0)。
闽ICP备15003702号
闽公网安备 35020302035102号